[riot-devel] initial gnu++0x compatibility for RIOT

Martin L. martin.landsmann at haw-hamburg.de
Mon Jun 3 07:45:57 CEST 2013


Hi all,

my apologise, I realize that I just "threw" the results of my efforts into the list and GIT
without communicating what I was working on in advance.

The goal was (is still) to make RIOT compliant to the new c++11 (gnu++0x) std., which enables to make use 
of the advantages of a recent GCC (>= 4.7), and of course to enable development with c++.
So the next step I would like to approach is to extend the gnu++0x compatibility for non-native platforms,
 such as MSB-A2 and MSP430 and test it on them.

Best regards,
Martin


More information about the devel mailing list