[riot-devel] Naming conventions and API functions

Martin Lenders mlenders at inf.fu-berlin.de
Mon May 27 14:29:34 CEST 2013

Hi list,
while extending the POSIX-Wrapper for some socket stuff I realized that
many functions in higher-end modules have very ambiguous names (I think I
stumbled upon 3 functions called close() ). While it mostly isn't a problem
if you only use one module, trying to compile two modules can make the
difference. Thus I would propose to name all public API functions in the
well-established manner <module_name>_<function_name>() and all defines
likewise <MODULE_NAME>_<MACRO_NAME>, etc., especially in the modules in the
sys/net directory ;-).

Kind regards
-------------- n?chster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20130527/9ee066dc/attachment.html>

More information about the devel mailing list