[riot-devel] Naming conventions and API functions
oliver.hahm at inria.fr
Wed May 29 16:39:50 CEST 2013
> Thus I would propose to name all public API functions in the
> well-established manner <module_name>_<function_name>() and all defines
> likewise <MODULE_NAME>_<MACRO_NAME>, etc., especially in the modules in the
> sys/net directory ;-).
I fully agree with Martin.
Let me use this opportunity to point to the recently documented coding
conventions for RIOT in the Github wiki .
Note, that these coding conventions are just my proposal so far. Please feel
free to comment on this.
panic("%s: CORRUPTED BTREE OR SOMETHING", __FUNCTION__);
More information about the devel