[riot-devel] Pull Request #1631: rename msg_* to blip_*

Martine Lenders authmillenon at gmail.com
Wed Sep 10 23:14:44 CEST 2014

Hi Kaspar,

what happened to note_*?


2014-09-10 20:11 GMT+02:00 Kaspar Schleiser <kaspar at schleiser.de>:

> Hi guys,
> my PR #1631 changes all msg_* function and structure names to blip_*.
> This is a prerequisite to a new messaging API that will be a lot more
> flexible.
> As I'd like to keep the old functions for compatibility and functional
> reasons, I'm just renaming them for now.
> The new API will allow messages bigger than "type"+"content", but will
> also be content agnostic (no type field).
> The old (now blip_*) api will stay the same. I'm thinking to also use them
> for the riot equivalent of "signals", which will be short messages with
> defined content, like "exit the thread if you receive this".
> Do you have any suggestions for a different name than "blip"?
> Kaspar
> _______________________________________________
> devel mailing list
> devel at riot-os.org
> http://lists.riot-os.org/mailman/listinfo/devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20140910/a4c949d4/attachment.html>

More information about the devel mailing list