[riot-devel] Pull Request #1631: rename msg_* to blip_*

David Lyon david.lyon at clixx.io
Thu Sep 11 04:13:36 CEST 2014

Hi Martine,

On 2014-09-11 07:14, Martine Lenders wrote:
>> The new API will allow messages bigger than "type"+"content", but
>> will also be content agnostic (no type field).
>> The old (now blip_*) api will stay the same. I'm thinking to also
>> use them for the riot equivalent of "signals", which will be short
>> messages with defined content, like "exit the thread if you receive
>> this".
>> Do you have any suggestions for a different name than "blip"?

What about something like "sysbus" ?

It would be a notional concept equivilent to D-Bus or 
Windows-Message-Queue on larger systems. It never needs to get that 
complex though, I'm sure.



More information about the devel mailing list