[riot-devel] Pull Request #1631: rename msg_* to blip_*

ROUSSEL Kévin Kevin.Roussel at inria.fr
Thu Sep 11 13:38:58 CEST 2014


Maybe 'ipc_*'?

Le 10/09/2014 20:11, Kaspar Schleiser a écrit :
> Hi guys,
>
> my PR #1631 changes all msg_* function and structure names to blip_*.
>
> This is a prerequisite to a new messaging API that will be a lot more
> flexible.
>
> As I'd like to keep the old functions for compatibility and functional
> reasons, I'm just renaming them for now.
>
> The new API will allow messages bigger than "type"+"content", but will
> also be content agnostic (no type field).
>
> The old (now blip_*) api will stay the same. I'm thinking to also use
> them for the riot equivalent of "signals", which will be short messages
> with defined content, like "exit the thread if you receive this".
>
> Do you have any suggestions for a different name than "blip"?
>
> Kaspar
> _______________________________________________
> devel mailing list
> devel at riot-os.org
> http://lists.riot-os.org/mailman/listinfo/devel

-- 


      Kévin Roussel
      Doctorant, projet LAR
      Équipe MADYNES, INRIA Nancy Grand-Est / LORIA
      Tél. : +33 3 54 95 86 27
      Kevin.Roussel at inria.fr



More information about the devel mailing list