[riot-devel] Pull Request #1631: rename msg_* to blip_*

Kaspar Schleiser kaspar at schleiser.de
Thu Sep 11 14:57:14 CEST 2014


On 09/11/14 14:41, Ludwig Ortmann wrote:
>> Do you have any suggestions for a different name than "blip"?
> I was also toying with "-gram" in my head but couldn't come up with
> anything short and meaningful.
> "grm" has a nice ring to it but no real meaning to the uninitiated.
> All in all I still like "msg" best.
Me too... That's why I renamed the old API in the first place.
IMHO the main IPC functionality should be msg_*. But now we have legacy 
code, and also some semantically more defined "messages" might be 
useful. So there's a second, higher level messaging type. I called it 
pulse at first, blip now.

At first, I tried integrating the sized buffer into our existing 
messages. That looked awful in code.

copy over type, copy over value, check for size, maybe copy over buffer, ...

Without type and content, every message transfer is essentially a 
memcpy. And with that, you can easily implement everything else.


More information about the devel mailing list