[riot-devel] Pull Request #1631: rename msg_* to blip_*

Kaspar Schleiser kaspar at schleiser.de
Thu Sep 11 15:30:17 CEST 2014


On 09/11/14 15:10, David Lyon wrote:
>> Me too... That's why I renamed the old API in the first place.
>> IMHO the main IPC functionality should be msg_*. But now we have
>> legacy code, and also some semantically more defined "messages" might
>> be useful.
> msg_* isn't confusing for me as an IPC component.
Just to clarify. I want the new API to be msg_send, msg_receive, 
msg_node (for the endpoints). This is supposed to be *the* IPC API.

Problem is, it's not feasable to add the new flexibility while retaining 
the old API while keeping the core IPC as it should be: minimal and with 
maximum performance.

BUT we have a lot of legacy code. So I implemented the old API using the 
new, simpler functions (they're basically just wrappers). But in order 
to reserve the msg_* names for the new core API to rule them all, the 
old functions need to get out of the namespace.

Initially I proposed msg_pulse_*. Noone liked pulse. Now I'm trying 
"blip" and ask for suggestions.


More information about the devel mailing list