[riot-devel] Unable to send/receive packets using telosb

Oleg Hahm oliver.hahm at inria.fr
Mon Aug 3 18:57:15 CEST 2015


Hi Shivani!

> I am trying to send/receive a packet from one telosb to another. I can see
> that the packet is sent from telosb1 but it never is received at telosb 2.
> I tried using the default example with telosb as well but even that does
> not work. Can someone help me debug this issue?
> 
> Additionally, I did find the exact same issue posted earlier on this forum
> but there was no solution[
> https://lists.riot-os.org/pipermail/devel/2014-October/001275.html].

The problem is that we're lacking any TelosB device here in Berlin and the
similar Zolertia Z1 doesn't reveal this bug - so, it's impossible to debug
this here. Maybe Kevin Roussel can help or I will try to borrow some TelosB
nodes.

Additionally, we're transiting to a new interface for peripheral devices and
network drivers which has not yet happened for the TelosB. I could imagine
that updating the TelosB to this new interface might already solve the
problem. If you can spare some time to help with this porting to the new
interface, it would speed up the process.

The porting guide is described here:
https://github.com/RIOT-OS/RIOT/wiki/Porting-Guide

For this and driver related questions, you will find further help here. I
would also advice to take a look at the driver for the at86rf2xx chip [1]

Cheers,
Oleg

[1] https://github.com/RIOT-OS/RIOT/tree/master/drivers/ng_at86rf2xx
-- 
dprintk(5, KERN_DEBUG "Jotti is een held!\n");
        linux-2.6.6/drivers/media/video/zoran_card.c
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20150803/4c8b88db/attachment.sig>


More information about the devel mailing list