[riot-devel] Configure Raspberry Pi as 802.15.4/6LoWPAN Border Gateway

Lennart Dührsen lennart.duehrsen at fu-berlin.de
Wed Aug 19 13:12:58 CEST 2015


Hi,

> Which kernel version are you running ? (Can you post output of uname -a
> ? ) If you're running an older version of kernel (and raspberry pi boot
> loader  / firmware) it won't support RPi 2 model B out of the box.

> Solution could be : "sudo apt-get update && sudo apt-get upgrade" on
> RPi 1 to get firmware and kernel upgraded. Once done, It should boot
> on RPi 2 Model B as well.

I downloaded the latest raspian image (2015-05-05) from raspberrypi.org,
and after dd'ing it to the SD-Card, it boots on both devices. I did an
apt-get update && apt-get upgrade before installing the new (self-build)
kernel, as recommended in the tutorial.

Output of uname -a is

Linux raspberrypi 4.1.6+ #1 PREEMPT Tue Aug 18 15:43:23 CEST 2015 armv6l
GNU/Linux

which says armv6l at the end, so I'm guessing I built a kernel for armv6
and replaced the original raspian kernel with it.

Another run of apt-get update / upgrade tells me there are no new
packages to install.

Best,
Lennart


More information about the devel mailing list