[riot-devel] Need help about RIOT radio communicate example

Thomas Eichinger thomas.eichinger at fu-berlin.de
Tue Mar 17 11:47:31 CET 2015


Hi Chen,

I can remember having the same problem with the telosb. I traced it down 
to the fact, that there are no interrupts triggered. Which is strange
as the same code is working on an other msp430/cc2420 platform (Zolertia Z1).
Maybe a misconfiguration somehow sneaked into the radio driver setup.

As I don’t have a TelosB anymore I can’t debug it in more detail right now,
but maybe this gives you a hint.

Best, Thomas

> On 16 Mar 2015, at 19:11, Oleg Hahm <oliver.hahm at inria.fr> wrote:
> 
> Hi Chen!
> 
>> I connect 2 telosb to 2 USB port and used 2 terminal to "make term" to each
>> telosb board.
> 
> I guess you're using the default example, right?
> 
>> Then I use one board to txtsnd to other board address. But there is no
>> reaction from the other board. (For native mode, the other should show
>> received packets).
> 
> Do you have the possibility to use a sniffer somehow? This could be helpful to
> check if it is a sender or a receiver problem. You could also try to use "make
> debug" or set ENABLE_DEBUG to 1 in drivers/cc2420/cc2420_rx.c (cc2420_tx.c
> respectively), to figure out what fails. The last time I checked the driver
> was working, but I cannot verify right now, because I don't have any
> cc2420-based hardware here.
> 
> Thomas, Kévin, could one of you verify the problem?
> 
>> I also use the .elf file in cooja simulation tool, there is no reaction for
>> receiving node also.
>> And I think the #1442 bug is not a matter about shell(explanation from 2014
>> dec version), I think it's a cc2420 driver related bug.
> 
> Have you tried without setting the channel and PAN?
> 
> Cheers,
> Oleg
> -- 
> The problem UDP jokes
> _______________________________________________
> devel mailing list
> devel at riot-os.org
> http://lists.riot-os.org/mailman/listinfo/devel



More information about the devel mailing list