[riot-devel] NSTF - Naming the stack

Martine Lenders authmillenon at gmail.com
Sun May 3 13:04:34 CEST 2015

Hi Oleg,

2015-05-03 12:59 GMT+02:00 Oleg Hahm <oliver.hahm at inria.fr>:
> > I'm not in favor of keeping the prefix. Three reasons:
> Forget about the ng, that's unrelated to the question that we need a name
> for
> the stack.

As stated in the previous e-mail:

> In all seriousness: I think Ludwigs proposal is better.

In other words: the new stack will be the default one, while smaller
implementations can be called `tiny_`, `micro_` or whatever. The proposed
architecture, that other implementations can use `ipv6/hdr.h`,
`ipv6/addr.h` or similar is mostly in place already.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20150503/42a1814d/attachment.html>

More information about the devel mailing list