[riot-devel] Fwd: tapsetup problem

samira afzal afzal.samira at gmail.com
Sun Sep 20 21:22:49 CEST 2015


Hi all,
Ii had sent a question about my problem but i didn't get any answer, if i
have to email to another address or sth is wrong please tell me. thanks to
all
---------- Forwarded message ----------
From: samira afzal <afzal.samira at gmail.com>
Date: Fri, Sep 18, 2015 at 5:09 PM
Subject: tapsetup problem
To: users at riot-os.org, devel at riot-os.org


Hi all,

I hope that i write in a correct place. i am newer on RIOT.  I've started
to learn about it. i amm using "
https://github.com/RIOT-OS/RIOT/wiki/Creating-your-first-RIOT-project" as
tutorial.


In the mentioned website i used command  ../../dist/tools/tapsetup/tapsetup
-c

tap0 and tap1 created successfully. Then i used make and then,
./bin/native/my_project.elf
tap0.
the result is:

usage: ./bin/native/my_project.elf [-i <id>] [-d] [-e|-E] [-o]
 help: ./bin/native/my_project.elf -h

Options:
-h          help
-i <id>     specify instance id (set by config module)
-s <seed>   specify srandom(3) seed (/dev/random is used instead of
            random(3) if the option is omitted)
-d          daemonize
-e          redirect stderr to file
-E          do not redirect stderr (i.e. leave sterr unchanged despite
            daemon/socket io)
-o          redirect stdout to file (/tmp/riot.stdout.PID) when not attached
            to socket

The order of command line arguments matters.
samira at samira-pc:~/RIOT/examples/my_project$



could u please guide me, what is the problem and how can i solve it? thanks
for your kind consideration


-- 

S. Afzal



-- 

S. Afzal
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20150920/6be22e63/attachment.html>


More information about the devel mailing list