[riot-devel] Fwd: tapsetup problem

Martine Lenders authmillenon at gmail.com
Sun Sep 27 23:27:00 CEST 2015


Hi,
make sure you have the `netdev2_tap` module included to your project. You
can do that by either adding the line

    USEMODULE += netdev2_tap

to your project or - more generally for all boards, not just native

    USEMODULE += gnrc_netif_default

If you want the OS to setup the device (recommended) also add the auto
initialization modules:

    USEMODULE += auto_init
    USEMODULE += auto_init_gnrc_netif

Cheers,
Martine

2015-09-26 21:50 GMT+02:00 Ludwig Knüpfer <ludwig.knuepfer at fu-berlin.de>:

> Hi,
>
> Apparently your project is not configured to use a transceiver.
>
> Cheers,
> Ludwig
>
> Am 20. September 2015 21:22:49 MESZ, schrieb samira afzal <
> afzal.samira at gmail.com>:
> >Hi all,
> >Ii had sent a question about my problem but i didn't get any answer, if
> >i
> >have to email to another address or sth is wrong please tell me. thanks
> >to
> >all
> >---------- Forwarded message ----------
> >From: samira afzal <afzal.samira at gmail.com>
> >Date: Fri, Sep 18, 2015 at 5:09 PM
> >Subject: tapsetup problem
> >To: users at riot-os.org, devel at riot-os.org
> >
> >
> >Hi all,
> >
> >I hope that i write in a correct place. i am newer on RIOT.  I've
> >started
> >to learn about it. i amm using "
> >https://github.com/RIOT-OS/RIOT/wiki/Creating-your-first-RIOT-project"
> >as
> >tutorial.
> >
> >
> >In the mentioned website i used command
> >../../dist/tools/tapsetup/tapsetup
> >-c
> >
> >tap0 and tap1 created successfully. Then i used make and then,
> >./bin/native/my_project.elf
> >tap0.
> >the result is:
> >
> >usage: ./bin/native/my_project.elf [-i <id>] [-d] [-e|-E] [-o]
> > help: ./bin/native/my_project.elf -h
> >
> >Options:
> >-h          help
> >-i <id>     specify instance id (set by config module)
> >-s <seed>   specify srandom(3) seed (/dev/random is used instead of
> >            random(3) if the option is omitted)
> >-d          daemonize
> >-e          redirect stderr to file
> >-E          do not redirect stderr (i.e. leave sterr unchanged despite
> >            daemon/socket io)
> >-o          redirect stdout to file (/tmp/riot.stdout.PID) when not
> >attached
> >            to socket
> >
> >The order of command line arguments matters.
> >samira at samira-pc:~/RIOT/examples/my_project$
> >
> >
> >
> >could u please guide me, what is the problem and how can i solve it?
> >thanks
> >for your kind consideration
>
> _______________________________________________
> devel mailing list
> devel at riot-os.org
> https://lists.riot-os.org/mailman/listinfo/devel
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20150927/c3b2334d/attachment.html>


More information about the devel mailing list