[riot-devel] Problem with "make" -lm missing.

MiTsArAs Jimaras Mits_swim at hotmail.com
Tue Aug 9 09:02:55 CEST 2016


Hello to all.
I am trying to build an app with  "make clean all flash term" on native platform, and all I get as a result that:

Building application "time" for "native" with MCU "native".

"make" -C /home/d/RIOT/boards/native
"make" -C /home/d/RIOT/boards/native/drivers
"make" -C /home/d/RIOT/core
"make" -C /home/d/RIOT/cpu/native
"make" -C /home/d/RIOT/cpu/native/periph
"make" -C /home/d/RIOT/drivers
"make" -C /home/d/RIOT/sys
"make" -C /home/d/RIOT/sys/auto_init
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/6.1.1/../../../../lib/libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/6.1.1/../../../../lib/libm.a when searching for -lm
/usr/bin/ld: skipping incompatible /lib/../lib/libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /lib/../lib/libm.a when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib/../lib/libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib/../lib/libm.a when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/6.1.1/../../../libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/6.1.1/../../../libm.a when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib/libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib/libm.a when searching for -lm
/usr/bin/ld: cannot find -lm
collect2: error: ld returned 1 exit status
make: *** [/home/darch/RIOT/examples/time/../../Makefile.include:261: all] Error 1

I am using ArchLinux. What am I doing wrong?
Thanks!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20160809/8233c151/attachment.html>


More information about the devel mailing list