[riot-devel] Raspberry & 6LoWPAN HowTo outdated

Alexander Aring aar at pengutronix.de
Wed Dec 14 09:58:53 CET 2016


Hi,

On 12/13/2016 11:16 PM, Tomek Jokii wrote:
> Hi,
> 
> the new Tutorial
> https://github.com/RIOT-Makers/wpan-raspbian/wiki/Create-a-generic-Raspbian-image-with-6LoWPAN-support
> works great. I've managed to run everything on RPI 2 and 3 without problems
> :)
> 

for info. This is not an issue of linux mainline kernel. It seems the
current 4.4 raspberry kernel spi controller driver is broken in some
ways...

Maybe it's only happend when doing large bulk transfer e.g. transfer
framebuffer.

Nevertheless 4.4 will not be the latest LTS kernel anymore, could be 4.9
[0] and hopefully raspbian use 4.9 then...

so it should work out of the box with 4.9 - until they broke again spi
with their own rpi patches.

- Alex

[0] http://kroah.com/log/blog/2016/09/06/4-dot-9-equals-equals-next-lts-kernel/


More information about the devel mailing list