[riot-devel] Coding conventions amendment

Martin martin.landsmann at haw-hamburg.de
Wed Oct 12 16:33:11 CEST 2016


Hi,

Am 10/12/2016 um 12:57 PM schrieb Ludwig Knüpfer:
> Hi,
>
>
>
> Am 12. Oktober 2016 09:48:28 MESZ, schrieb Oleg Hahm <oliver.hahm at inria.fr>:
>> Dear rolling IoTlers,
>>
>> as far I'm concerned it has been an undocumented coding convention so
>> far to
>> use `int` or `unsigned int` for iterator variables in a loop instead of
>> fixed
>> width integer types. Does anybody object to adding this to the coding
>> conventions explicitly?
> What about `size_t`?
+1 for size_t
>
> Cheers,
> Ludwig
>
> _______________________________________________
> devel mailing list
> devel at riot-os.org
> https://lists.riot-os.org/mailman/listinfo/devel
Best regards,
Martin


More information about the devel mailing list