[riot-devel] Coding conventions amendment

Martin martin.landsmann at haw-hamburg.de
Wed Oct 12 16:52:37 CEST 2016


Am 10/12/2016 um 04:37 PM schrieb Oleg Hahm:
> Hi!
> On Wed, Oct 12, 2016 at 12:57:50PM +0200, Ludwig Knüpfer wrote:
>> Am 12. Oktober 2016 09:48:28 MESZ, schrieb Oleg Hahm <oliver.hahm at inria.fr>:
>>> as far I'm concerned it has been an undocumented coding convention so far
>>> to use `int` or `unsigned int` for iterator variables in a loop instead of
>>> fixed width integer types. Does anybody object to adding this to the coding
>>> conventions explicitly?
>> What about `size_t`?
> I don't see a reason against `size_t` - but also no good reason that speaks
> for it. What's the rationale?
size_t is suited best to be used for iterating array indices and never 
overflow holding them [1].

[1] http://stackoverflow.com/a/2550799
> Cheers,
> Oleg
> _______________________________________________
> devel mailing list
> devel at riot-os.org
> https://lists.riot-os.org/mailman/listinfo/devel
Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20161012/6aae63f8/attachment.html>

More information about the devel mailing list