[riot-devel] IPv4 support

Martine Lenders mail at martine-lenders.eu
Fri Aug 18 16:40:14 CEST 2017


Hi Oleg,

2017-08-18 15:37 GMT+02:00 Oleg Hahm <oleg at riot-os.org>:

> Dear Ameya!
>
> On Fri, Aug 18, 2017 at 06:38:31PM +0530, Ameya Joshi wrote:
> > Does the latest version of RIOT support IPv4?
>
> RIOT supports the lwip network stack which supports IPv4. However, AFAIK
> there
> is no IPv4 support for application interface "sock". Martine, correct me if
> I'm wrong.
>

You are wrong ;-). Compile with `lwip_ipv4` and `lwip_sock_udp` or
`lwip_sock_tcp` to use UDP over IPv4 or TCP over IPv4, respectively.
However, this might only work for Ethernet-based L2 protocols. IPv4 over
IEEE 802.15.4 is not specified and I'm not sure if it would work with lwIP.

Cheers,
Martine
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20170818/fedd832b/attachment.html>


More information about the devel mailing list