[riot-devel] TCP on RIOT OS

Martine Lenders mail at martine-lenders.eu
Tue May 22 14:03:18 CEST 2018


Hi Theresa,

were you using link local addresses (i.e. are they prefixed `fe80::/64`)
for your trials? If yes, newer versions require to also provide an
interface with that (as it is the case e.g. also on Linux) so this might be
your problem. The client and server needs to be fixed then of course to
have the interface provided or warn the user that it is missing..

Best regards,
Martine

2018-05-22 9:37 GMT+02:00 "Theresa Müller" <theresa2596 at web.de>:

> Hi everyone,
>
> I am currently trying to use TCP on RIOT, but I'm having problems with it,
> since the "gnrc_tcp_server" and "gnrc_tcp_client" tests are not working on
> the latest version of RIOT. I tried to run these tests on the 2017.01
> release where they were added the first time and everything works fine
> here, but when I run them on the 2018.01 or 2018.04 release, wireshark
> doesn't show any TCP pakets and the client always receives a timeout after
> a while, so somehow the client and the server aren't able to establish a
> connection. Maybe one of you knows what caused this change in behaviour and
> how this could be fixed.
>
> Thanks a lot for your help!
>
> Best regards,
> Theresa
>
> _______________________________________________
> devel mailing list
> devel at riot-os.org
> https://lists.riot-os.org/mailman/listinfo/devel
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/devel/attachments/20180522/3fd7c2c6/attachment.html>


More information about the devel mailing list