<div dir="ltr">Hi Theresa,<div><br></div><div>were you using link local addresses (i.e. are they prefixed `fe80::/64`) for your trials? If yes, newer versions require to also provide an interface with that (as it is the case e.g. also on Linux) so this might be your problem. The client and server needs to be fixed then of course to have the interface provided or warn the user that it is missing..</div><div><br></div><div>Best regards,</div><div>Martine</div></div><div class="gmail_extra"><br><div class="gmail_quote">2018-05-22 9:37 GMT+02:00 "Theresa Müller" <span dir="ltr"><<a href="mailto:theresa2596@web.de" target="_blank">theresa2596@web.de</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div style="font-family:Verdana;font-size:12.0px"><div>Hi everyone, </div>

<div> </div>

<div>I am currently trying to use TCP on RIOT, but I'm having problems with it, since the "gnrc_tcp_server" and "gnrc_tcp_client" tests are not working on the latest version of RIOT. I tried to run these tests on the 2017.01 release where they were added the first time and everything works fine here, but when I run them on the 2018.01 or 2018.04 release, wireshark doesn't show any TCP pakets and the client always receives a timeout after a while, so somehow the client and the server aren't able to establish a connection. Maybe one of you knows what caused this change in behaviour and how this could be fixed. </div>

<div> </div>

<div>Thanks a lot for your help! </div>

<div> </div>

<div>Best regards, </div><span class="HOEnZb"><font color="#888888">

<div>Theresa</div></font></span></div></div>
<br>______________________________<wbr>_________________<br>
devel mailing list<br>
<a href="mailto:devel@riot-os.org">devel@riot-os.org</a><br>
<a href="https://lists.riot-os.org/mailman/listinfo/devel" rel="noreferrer" target="_blank">https://lists.riot-os.org/<wbr>mailman/listinfo/devel</a><br>
<br></blockquote></div><br></div>