<div dir="ltr"><div class="gmail-gE gmail-iv gmail-gt" style="padding:20px 0px 0px;font-size:12.8px;font-family:Roboto,RobotoDraft,Helvetica,Arial,sans-serif"><table cellpadding="0" class="gmail-cf gmail-gJ" style="border-collapse:collapse;margin-top:0px;width:auto;font-size:0.875rem;letter-spacing:0.2px;display:block"><tbody style="display:block"></tbody></table><span style="font-family:Arial,Helvetica,sans-serif;font-size:small">Hi! I'm a new RIOT user, I have been programming MCU in C for several years in Windows under a full IDE environment. This is my first time not only with RIOT but with managing Makefiles myself instead of letting the IDE do all the work. I managed to get RIOT compiled on my Windows machine with MinGW. I was able to add my custom app and being able to compile it (a single main.c file).</span></div><div class="gmail-" style="font-family:Roboto,RobotoDraft,Helvetica,Arial,sans-serif;font-size:medium"><div id="gmail-:4we" class="gmail-ii gmail-gt" style="font-size:12.8px;direction:ltr;margin:8px 0px 0px;padding:0px"><div id="gmail-:4wd" class="gmail-a3s gmail-aXjCH" tabindex="-1" style="overflow:hidden;font-variant-numeric:normal;font-variant-east-asian:normal;font-stretch:normal;font-size:small;line-height:1.5;font-family:Arial,Helvetica,sans-serif"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div>I'm facing a problem now that I can't solve, I have been struggling with it in the last few days. I have generated some code with the STM32Cube. It just generates all the code to be able to interact with STM32 peripherals. I added the "INCLUDES +=" to my Makefile to be able to include the header files but I'm having problems on the linking stage I think.<br></div><div><br></div><div>I'm getting this error when compiling:¬†<a href="https://pastebin.com/p2xCpqJJ" target="_blank">https://pastebin.com/p2xCpqJJ</a>, about the HAL functions the linker couldn't find. Here you can download my entire RIOT project¬†<a href="https://drive.google.com/file/d/1orTzemm5SRDYiQJOJR6_BHFlZOoDxXMS/view?usp=sharing" target="_blank">https://drive.google.com/file/d/1orTzemm5SRDYiQJOJR6_BHFlZOoDxXMS/view?usp=sharing</a>. My application is on RIOT/cansat. I created a "config" folder with a .h and .c file and they are being linked correctly, I don't know why the RIOT/cansat/stm32cube folder is having problems.</div><div><br></div><div>Any help will be really appreciated! Thank you very much! :)</div></div></div></div></div></div></div></div>