[riot-notifications] [RIOT-OS/RIOT] vagrant: flashing ATSAMR21 fails (#4427)

Wulfric Lee notifications at github.com
Sat Feb 16 09:33:12 CET 2019


I've encountered this problem before, it's very weird in my case, I plug a USB wire into my CMSIS-DAP debugger and a USB HUB which connected to my computer, at first I plugged it in the 2nd slot of my USB HUB, and I ran OpenOCD, I was told
```
Error: CMSIS-DAP command CMD_INFO failed.
```
then I tried the first slot, it just worked! And I try the second slot again, the error prompted to me as before, I tried each slot in my HUB, the result is different everytime, sometimes even the first slot prompted the error to me also, I was like... What the heck???
![](https://encrypted-tbn0.gstatic.com/images?q=tbn:ANd9GcS2_QumP7JEUk9p2bZCUemaPJaYOYGLzwELtg-6EVMrFTREH6m1oA)
And suddenly I realized the USB wire I used to connect debugger and HUB is like... more than 1 meter long, so maybe it is a bug caused by electrical characteristics of my USB wire, I replaced the wire with another one which is about 20cm long, and the result is, **whichever** slot I plugged in, it just worked.
So, here is my advisement:
### If your USB wire is more than 0.5 meter, replaced the wire with a shorter one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/4427#issuecomment-464315094
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190216/f16f95cf/attachment-0001.html>


More information about the notifications mailing list