[riot-notifications] [RIOT-OS/RIOT] Problem flashing the Bluepill (STM32F130C8) (#11030)

Khayhen notifications at github.com
Mon Feb 18 10:43:00 CET 2019


Hi, I'm trying to setup a 6LoWPAN network and due to limited budget and resources, I decided to use the bluepill board (STM32F130C8) with the MRF24J40 radio module. However, I'm unable to flash the board. I'm using a FTDI USB-UART programmer with the pins connected in the following way and with boot 0 set to 1 and boot 1 set to 0:
5V    - 5V
GND - GND
TX    - A9
RX    - A10
 When I try to flash it with task-01, I get the following error.
<pre>### Flashing Target ###
Open On-Chip Debugger 0.10.0+dev-00634-gdb070eb8 (2018-12-31-01:14)
Licensed under GNU GPL v2
For bug reports, read
	http://openocd.org/doc/doxygen/bugs.html
WARNING: interface/stlink-v2.cfg is deprecated, please switch to interface/stlink.cfg
hla_swd
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 1000 kHz
adapter_nsrst_delay: 100
none separate
none separate
Info : clock speed 1000 kHz
Error: open failed


/home/khayhen/Tutorials/task-01/../RIOT/Makefile.include:390: recipe for target 'flash' failed
make: *** [flash] Error 1
</pre>
Based on the [documentation](https://doc.riot-os.org/group__boards__bluepill.html), I tried connecting the TX and RX pins to A3 and A2 respectively but still get the same error. What am I doing wrong? (I'm able to program the board with the Arduino IDE, so its not a defect in the board) Any help will be much appreciated thank you.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11030
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190218/cfe3329a/attachment.html>


More information about the notifications mailing list