[riot-notifications] [RIOT-OS/RIOT] Problem flashing the Bluepill (STM32F130C8) (#11030)

Khayhen notifications at github.com
Sun Feb 24 07:55:07 CET 2019


Hi, so I managed to get my STLink V2 but I'm not sure if its flashing properly. So when I flash with the basic task-01, I get a "Done Flashing" but when I hook up a USB-UART converter to pins A2/A3 and open pyterm, I don't get any messages. I also wrote another simple blink code to blink PC13(which was tested on an arduino board succesfully). I flashed the bluepill and got the same message but the on board LED doesn't blink. This is the message I get upon flashing.
<pre>### Flashing Target ###
Open On-Chip Debugger 0.10.0+dev-00634-gdb070eb8 (2018-12-31-01:14)
Licensed under GNU GPL v2
For bug reports, read
	http://openocd.org/doc/doxygen/bugs.html
WARNING: interface/stlink-v2.cfg is deprecated, please switch to interface/stlink.cfg
hla_swd
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 1000 kHz
adapter_nsrst_delay: 100
none separate
none separate
Info : clock speed 1000 kHz
Info : STLINK V2J17S4 (API v2) VID:PID 0483:3748
Info : Target voltage: 3.258964
Info : stm32f1x.cpu: hardware has 6 breakpoints, 4 watchpoints
Info : Listening on port 42327 for gdb connections
    TargetName         Type       Endian TapName            State       
--  ------------------ ---------- ------ ------------------ ------------
 0* stm32f1x.cpu       hla_target little stm32f1x.cpu       running
target halted due to debug-request, current mode: Thread 
xPSR: 0x01000000 pc: 0x08000464 msp: 0x20000200
auto erase enabled
Info : device id = 0x20036410
Info : flash size = 128kbytes
target halted due to breakpoint, current mode: Thread 
xPSR: 0x61000000 pc: 0x2000003a msp: 0x20000200
wrote 18432 bytes from file /home/khayhen/Tutorials/task-01/bin/bluepill/Task01.elf in 1.066452s (16.878 KiB/s)
target halted due to breakpoint, current mode: Thread 
xPSR: 0x61000000 pc: 0x2000002e msp: 0x20000200
target halted due to breakpoint, current mode: Thread 
xPSR: 0x61000000 pc: 0x2000002e msp: 0x20000200
verified 17540 bytes in 0.294756s (58.112 KiB/s)
shutdown command invoked
Done flashing
</pre>

This is the mesage I get upon opening pyterm.
<pre>/home/khayhen/Tutorials/RIOT/dist/tools/pyterm/pyterm -p "/dev/ttyUSB0" -b "115200"
No handlers could be found for logger "root"
2019-02-24 14:31:59,958 - INFO # Connect to serial port /dev/ttyUSB0
Welcome to pyterm!
Type '/exit' to exit.
</pre>
I have a feeling that it is not flashing properly. I notice a couple of things, one of which is that the boards file in the RIOT directory for tutorials and latest RIOT release are different, although I have tried both boards file and still get the same result. Secondly, is that based on the bluepill [doc](https://doc.riot-os.org/group__boards__bluepill.html), the bluepill is defaulted to flash with 64kb but I seem to be flashing it with 128kb but I'm not sure if this a problem. Anything you can recommend to fix this problem? Any help will be much appreciated. Thank you for your time.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11030#issuecomment-466740023
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190223/3b314519/attachment.html>


More information about the notifications mailing list