[riot-notifications] [RIOT-OS/RIOT] Problem flashing the Bluepill (STM32F130C8) (#11030)

MrKevinWeiss notifications at github.com
Sun Feb 24 11:28:41 CET 2019


The stdio uart pins usually default to device 0.  According to [the periph configuration](https://github.com/RIOT-OS/RIOT/blob/master/boards/common/stm32f103c8/include/periph_conf.h) device 0 is actually a10 and a9.
```
        .rx_pin     = GPIO_PIN(PORT_A, 10),
        .tx_pin     = GPIO_PIN(PORT_A, 9),
```

So you could try to get terminal output by connecting to those pins.

_(A2 and A3 are for the rom uart bootloader I think)_

As for the LED it should be C13 and you should see it flashing (if something else isn't already enabled).  A few things to note about the LED is that it is sinking, so a 0 turns it on and a 1 turns it off.  Also the QA for the bluepills are not the best (that is one thing that keeps the cost so low) some have the LED connected to different pins.  This is the reason why there are so many different binaries for the [dfu_util bootloader](https://github.com/rogerclarkmelbourne/STM32duino-bootloader/tree/master/bootloader_only_binaries).  Now if you already tested the hardware it is probably not that.  You could also try to flash the RIOT/tests/led/ application.

Your almost there!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11030#issuecomment-466760819
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190224/10d804e0/attachment-0001.html>


More information about the notifications mailing list