[riot-notifications] [RIOT-OS/RIOT] tests/leds: initialize led0 by default (#10322)

Sebastian Meiling notifications at github.com
Mon Feb 25 17:07:39 CET 2019


smlng requested changes on this pull request.



> @@ -1,3 +1,6 @@
 include ../Makefile.tests_common
 
+# Some boards do not initialize LED0 by default
+CFLAGS=-DAUTO_INIT_LED0

I'm not sure about this PR, or better about the usage (and usefulness) of the `AUTO_INIT_LED0` macro in general.
Because it is not consistently used for all boards, a close look reveals it is mostly used by the nucleos but most other boards don't have it

```
git grep AUTO_INIT_LED0 
boards/b-l072z-lrwan1/board.c:#ifdef AUTO_INIT_LED0
boards/b-l072z-lrwan1/include/gpio_params.h:#ifdef AUTO_INIT_LED0
boards/b-l475e-iot01a/board.c:#ifdef AUTO_INIT_LED0
boards/b-l475e-iot01a/include/gpio_params.h:#ifdef AUTO_INIT_LED0
boards/common/nucleo/board.c:#ifdef AUTO_INIT_LED0
boards/common/nucleo144/include/board.h:#define AUTO_INIT_LED0
boards/common/nucleo32/include/gpio_params.h:#ifndef AUTO_INIT_LED0
boards/common/nucleo32/include/gpio_params.h:#endif /* AUTO_INIT_LED0 */
boards/common/nucleo64/include/gpio_params.h:#ifdef AUTO_INIT_LED0
boards/lobaro-lorabox/include/board.h:#define AUTO_INIT_LED0
boards/lobaro-lorabox/include/gpio_params.h:#ifdef AUTO_INIT_LED0
boards/sodaq-sara-aff/board.c:    #ifdef AUTO_INIT_LED0
```

To me it looks like we should either remove its usage completely or specify (and implements) its usage properly and for all boards consistently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/10322#pullrequestreview-207482274
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190225/521d9feb/attachment.html>


More information about the notifications mailing list