[riot-notifications] [RIOT-OS/RIOT] tools/print_toolchain_versions.sh: use lsb_release. (#10770)

Sebastian Meiling notifications at github.com
Wed Jan 16 08:53:40 CET 2019


to clarify: I'm not against using `lsb-release` I just wouldn't make it (kind of) a dependency of the RIOT build or CI system, as long as there is another easy method, i.e. `grep` through `/etc/os-release`, to deduce the OS variant and version on many Linux distros. 

So I'm still in favour of simply having both possibilities in that script without requiring every linux user to have that extra tool installed if it is not needed. Having it in riot docker doesn't hurt and will likely not increase the container size by much - though I think we should really look into that anyway.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/10770#issuecomment-454684705
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190115/80eb330a/attachment.html>


More information about the notifications mailing list