[riot-notifications] [RIOT-OS/RIOT] tools/print_toolchain_versions.sh: use lsb_release. (#10770)

Joakim Nohlgård notifications at github.com
Fri Jan 18 20:50:15 CET 2019


NACK from me, the lsb_release adds an additional dependency for the host system. The fact that it is a shell script that needs to be executed is another problem. If you do a check through the recent versions of all popular releases you will find that all of them provide /etc/os-release, but not all provide lsb_release by default.
See my brief scan of some common Linux distros on the Docker hub in https://github.com/RIOT-OS/RIOT/pull/9961#discussion_r218819492

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/10770#issuecomment-455666976
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190118/702abf18/attachment-0001.html>


More information about the notifications mailing list