[riot-notifications] [RIOT-OS/RIOT] Send message from host PC to networking boards via border_router (#11534)

talalong notifications at github.com
Sun Jul 7 13:48:30 CEST 2019


I am sorry, but I have to reopen this question again. Because I have another problem using `border_router` and `networking` base on my setup above.
I was saying that:
> ... And also ping from my host PC <-> sam_node via sam_router worked as well.

Is not working anymore. Or at least it does not work partially.
same setup and same code from gnrc_border_router/ gnrc_networking.
What I can do is `ping6` to `sam_node` via `sam_router `on my `vagrant` virtual maschine and **NOT** from my macOS terminal interface anymore (or was I dreamingT_T ).
But I am 70% sure that I was able to ping6 to sam_node on vagrant VM **AND** on macOS terminal.
here is `ifconfig` on vagrant VM.

> vagrant at vagrant:~/Tutorials$ ifconfig
> enp0s3    Link encap:Ethernet  HWaddr 08:00:27:70:75:6c  
>           inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
>           inet6 addr: fe80::a00:27ff:fe70:756c/64 Scope:Link
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:4440 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:3607 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000 
>           RX bytes:345724 (345.7 KB)  TX bytes:368816 (368.8 KB)
> 
> lo        Link encap:Local Loopback  
>           inet addr:127.0.0.1  Mask:255.0.0.0
>           inet6 addr: ::1/128 Scope:Host
>           inet6 addr: fd00:dead:beef::1/128 Scope:Global
>           UP LOOPBACK RUNNING  MTU:65536  Metric:1
>           RX packets:9 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1 
>           RX bytes:1162 (1.1 KB)  TX bytes:1162 (1.1 KB)
> 
> tap0      Link encap:Ethernet  HWaddr aa:91:87:9f:41:22  
>           inet6 addr: fe80::a891:87ff:fe9f:4122/64 Scope:Link
>           inet6 addr: fe80::1/64 Scope:Link
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:342 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:349 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000 
>           RX bytes:27202 (27.2 KB)  TX bytes:29220 (29.2 KB)

Here `ifconfig` on MacOS:

>Tutorials talalong$ ifconfig
> lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
> 	options=1203<RXCSUM,TXCSUM,TXSTATUS,SW_TIMESTAMP>
> 	inet 127.0.0.1 netmask 0xff000000 
> 	inet6 ::1 prefixlen 128 
> 	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
> 	nd6 options=201<PERFORMNUD,DAD>
> gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
> stf0: flags=0<> mtu 1280
> XHC20: flags=0<> mtu 0
> en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
> 	ether b8:e8:56:4a:89:1c 
> 	inet6 fe80::f5:564f:178d:df48%en0 prefixlen 64 secured scopeid 0x5 
> 	inet 192.168.1.20 netmask 0xffffff00 broadcast 192.168.1.255
> 	nd6 options=201<PERFORMNUD,DAD>
> 	media: autoselect
> 	status: active

> p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
> 	ether 0a:e8:56:4a:89:1c 
> 	media: autoselect
> 	status: inactive

> awdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1484
> 	ether da:4a:52:e3:08:4d 
> 	inet6 fe80::d84a:52ff:fee3:84d%awdl0 prefixlen 64 scopeid 0x7 
> 	nd6 options=201<PERFORMNUD,DAD>
> 	media: autoselect
> 	status: active

> en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
> 	options=60<TSO4,TSO6>
> 	ether 72:00:01:34:03:10 
> 	media: autoselect <full-duplex>
> 	status: inactive

> en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
> 	options=60<TSO4,TSO6>
> 	ether 72:00:01:34:03:11 
> 	media: autoselect <full-duplex>
> 	status: inactive

> bridge0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
> 	options=63<RXCSUM,TXCSUM,TSO4,TSO6>
> 	ether 72:00:01:34:03:10 
> 	Configuration:
> 		id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
> 		maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
> 		root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
> 		ipfilter disabled flags 0x2
> 	member: en1 flags=3<LEARNING,DISCOVER>
> 	        ifmaxaddr 0 port 8 priority 0 path cost 0
> 	member: en2 flags=3<LEARNING,DISCOVER>
> 	        ifmaxaddr 0 port 9 priority 0 path cost 0
> 	media: <unknown type>
> 	status: inactive --> why is that inactive?

> utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 2000
> 	inet6 fe80::221e:b0b6:37e7:49f4%utun0 prefixlen 64 scopeid 0xb 
> 	nd6 options=201<PERFORMNUD,DAD>
> utun2: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380
> 	inet6 fe80::1324:90a6:d38e:2b56%utun2 prefixlen 64 scopeid 0xd 
> 	nd6 options=201<PERFORMNUD,DAD>
> utun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380
> 	inet6 fe80::4275:2137:d490:2794%utun1 prefixlen 64 scopeid 0xe 
> 	nd6 options=201<PERFORMNUD,DAD>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11534#issuecomment-508993217
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190707/6f9528b0/attachment-0001.html>


More information about the notifications mailing list