[riot-notifications] [RIOT-OS/RIOT] nrf52: Add riotboot support (#11126)

Gaëtan Harter notifications at github.com
Wed Jul 24 11:53:00 CEST 2019


The command still works for me without error: 

(filesize 12560)

```
BOARD=nrf52dk make -C tests/riotboot riotboot/flash-slot1


### Flashing Target ###
### Flashing at base address 0x0 with offset 266240 ###
...

Cortex-M4 identified.
Halting CPU for downloading file.
Downloading file [/home/harter/work/git/RIOT/tests/riotboot/bin/nrf52dk/tests_riotboot-slot1.0.riot.bin]...
Comparing flash   [100%] Done.
Erasing flash     [100%] Done.
Programming flash [100%] Done.
Verifying flash   [100%] Done.
J-Link: Flash download: Bank 0 @ 0x00000000: 1 range affected (16384 bytes)
J-Link: Flash download: Total time needed: 0.290s (Prepare: 0.042s, Compare: 0.004s, Erase: 0.000s, Program: 0.234s, Verify: 0.000s, Restore: 0.008s)
O.K.

Reset delay: 0 ms
Reset type NORMAL: Resets core & peripherals via SYSRESETREQ & VECTRESET bit.
Reset: Halt core after reset via DEMCR.VC_CORERESET.
Reset: Reset device via AIRCR.SYSRESETREQ.



Script processing completed.

make: Leaving directory '/home/harter/work/git/RIOT/tests/riotboot'
```

However it already happened to me that `reset` with JLink was doing nothing, and that it was working with `openocd`.
On my test machine I am using `openocd` for the board with https://github.com/RIOT-OS/RIOT/pull/11470 too.


-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/11126#issuecomment-514564481
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190724/2abf71bc/attachment-0001.htm>


More information about the notifications mailing list