[riot-notifications] [RIOT-OS/RIOT] TI CC3200 SimpleLink RIOT support (#11866)

Wlad Meixner notifications at github.com
Wed Jul 24 13:16:54 CEST 2019


gosticks commented on this pull request.



> +    /* SWD mode */
+    if (((HWREG(HIB1P2_BASE + HIB1P2_O_SOP_SENSE_VALUE) & 0xFF) == 0x2)) {
+        HWREG(OCP_SHARED_BASE + OCP_SHARED_O_GPIO_PAD_CONFIG_28) =
+                ((HWREG(OCP_SHARED_BASE + OCP_SHARED_O_GPIO_PAD_CONFIG_28) &
+                  ~0xC0F) |
+                 0x2);
+        HWREG(OCP_SHARED_BASE + OCP_SHARED_O_GPIO_PAD_CONFIG_29) =
+                ((HWREG(OCP_SHARED_BASE + OCP_SHARED_O_GPIO_PAD_CONFIG_29) &
+                  ~0xC0F) |
+                 0x2);
+    }
+
+    /* Override JTAG mux */
+    HWREG(OCP_SHARED_BASE + OCP_SHARED_O_CC3XX_DEV_PADCONF) |= 0x2;
+
+    /* Change UART pins(55,57) mode to PIN_MODE_0 if they are in PIN_MODE_1

PIN_MODE_0 is default/GPIO PIN_MODE_1 is UART. I tried starting the board without that init and it still worked fine... I don't know why it is done that way by TI, but I could simply remove it. The UART driver takes care of it already. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/11866#discussion_r306756812
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190724/3117931f/attachment.htm>


More information about the notifications mailing list