[riot-notifications] [RIOT-OS/RIOT] TCP lwIP Error Connecting Sock Problem (#11910)

Gunar Schorcht notifications at github.com
Sat Jul 27 18:50:34 CEST 2019


@mmaxus35 I could get your `tcp-simple-server` working with the changes described above (I will provide a PR). However, you must not mix GNRC and `lwIP` in you application. Either you use GNRC or you use `lwIP`. That is, you must not use `gnrc_*` modules in your makefile or `gnrc_*` functions in your application.

 Your application works with the changes described and the following modules:
```
# module as used in tests/lwip 
USEMODULE += lwip lwip_ipv6_autoconfig lwip_sock_ip lwip_netdev
USEMODULE += lwip_tcp lwip_sock_tcp
USEMODULE += ipv6_addr
USEMODULE += shell
USEMODULE += shell_commands
USEMODULE += ps
USEMODULE += od
USEMODULE += netdev_default

# additional modules for the application
USEMODULE += netstats_l2
USEMODULE += netstats_ipv6
USEMODULE += netstats_rpl
USEMODULE += esp_wifi
```
I had a netcat running as TCP server on remote machine using with command `nc -6l 12345` and could receive the string `Hello!` from ESP32.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11910#issuecomment-515698140
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190727/cbf1f928/attachment.htm>


More information about the notifications mailing list