[riot-notifications] [RIOT-OS/RIOT] Makefile.include: require make version 4. (#10554)

Gaëtan Harter notifications at github.com
Mon Jun 3 10:24:54 CEST 2019


I would like to update the phrasing on the error message. Could you put it as a `deprecation` warning somehow with a expiry date ? (== 2 releases)

As currently, we do not rely on stem target specific variables with multiple definitions, and no directories targets is currently in. We are thinking about the last one but could be done with `*/.` with a documentation until then.

For the canned recipes, using instead the `default-flash-recipe` and `flash-recipe ?= $(default-flash-recipe)` is I think a better alternative as it gives a name that can be used to the default behavior.

I did not know `--output-sync` was only added in `3.8.2` though…


-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/10554#issuecomment-498161459
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190603/83f125a2/attachment.html>


More information about the notifications mailing list