[riot-notifications] [RIOT-OS/RIOT] cpu/atmega*/ldscripts_compat: add command to generate ldscript (#11615)

Sebastian Meiling notifications at github.com
Mon Jun 3 13:37:10 CEST 2019


smlng requested changes on this pull request.



> @@ -6,3 +6,9 @@ overriden to configure ROM and RAM length.
 
 This ldscript is used for supporting older versions on avr-binutils like on
 ubuntu xenial.
+
+Generated by extracting the output of
+
+    avr-gcc -Wl,--verbose --mmcu=$(CPU)

I get an error for this command, need to use `-mmcu` instead of `--mmcu` (no double dashes)

what I ran is 
```shell
avr-gcc -Wl,--verbose -mmcu=atmega1281
```

I have avr-binutils 2.32 and avr-gcc 8.3.0 (on macOS installed via brew)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/11615#pullrequestreview-244824925
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190603/a9486452/attachment.html>


More information about the notifications mailing list