[riot-notifications] [RIOT-OS/RIOT] openmote-b: Cannot flash board with USB more than once (#11684)

MrKevinWeiss notifications at github.com
Thu Jun 13 09:31:36 CEST 2019


If you are experiencing an issue with openmote-b boards only being able to flash with usb empty boards and not reflash, meaning either just arrived from purchase or erased with the JLink interface, please read the following:

This is an issue to provide information regarding some manufacturer problems with the openmote-b boards.  I believe this was the issue with #11031 as well.

The manufacturer stated:

> We had various people reporting the same behaviour and tracked it down to the firmware being executed by the MSP430 that manages the bootloading. 
Since programming the MSP430 is not intended for final users, I see two possible solutions:
1 - You ship back the devices, we reprogram them and ship them back to you
2 - We let you know the steps to reprogram the devices; you will need a MSP430-FET programmer and a special cable

For testing purposes I have found setting the `CCA_BACKDOOR_ACTIVE_LEVEL` to 1 instead of 0 allows for reflashing (however with battery power I think it could never execute main code) and if this is done on a board that is working it may lock it up.



-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11684
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190613/83296dfd/attachment.html>


More information about the notifications mailing list