[riot-notifications] [RIOT-OS/RIOT] murdock and tests using `utf-8` characters (#11691)

Gaƫtan Harter notifications at github.com
Thu Jun 13 13:46:47 CEST 2019


#### Description

Tests using `utf-8` characters fails in murdock `native` but work my developer machine.

* tests/lua_loader: run the test in CI #11686
* tests/pkg_u8g2: run the test in CI #11687
* tests/pthread_rwlock: run the test in CI #11688 

For the boards tests, it looks like they work correctly on the nodes but the report is not described as an `utf-8` document so show invalid output in the reports by default.

Related to https://github.com/RIOT-OS/RIOT/pull/9095#issuecomment-470097586

#### Steps to reproduce the issue

Enable the given tests in CI and check the output.

#### Expected results

* Tests work in `native` correctly.
* Tests report show the `utf-8` characters by default on boards.

#### Actual results

* Tests using `utf-8` fail with `UnicodeEncodeError: 'ascii' codec can't encode characters in position` for native
* Encoding for file tests results is `utf-8`.

#### Versions

This is murdock specific so not RIOT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11691
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190613/b3992f1e/attachment.html>


More information about the notifications mailing list