[riot-notifications] [RIOT-OS/RIOT] riotboot: no updates will be possible after 19.1.2038 (#11735)

Kaspar Schleiser notifications at github.com
Tue Jun 25 20:53:12 CEST 2019


We're using *unsigned*, not signed 32bit integers.

Thus there's like 68 more years to update to a version that changes the logic, *after* 2038. If in the heat of 2038 panic someone finds out we're using only 32bits, we can still change the ```APP_VER ?= $(EPOCH)``` and have 2 billion more update version left.

And then there are easy solutions to reset the number. Only one image (let's say it has version 0xffffffff) needs to first flash a newer image with a lower version, validate it, then invalidate the active slot. Just in case our cute little 20 line bootloader is still around.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11735#issuecomment-505575385
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190625/77bd79e9/attachment.html>


More information about the notifications mailing list