[riot-notifications] [RIOT-OS/RIOT] gnrc_sixlowpan: don't use PRIx8 (#11124)

Marian Buschsieweke notifications at github.com
Thu Mar 7 21:15:43 CET 2019


maribu commented on this pull request.



> @@ -222,8 +217,7 @@ static void _receive(gnrc_pktsnip_t *pkt)
     }
 #endif
     else {
-        DEBUG("6lo: dispatch %02" PRIx8 " ... is not supported\n",
-              dispatch[0]);
+        DEBUG("6lo: dispatch %02x... is not supported\n", dispatch[0]);

As I said, I don't know whether this is indeed a bug or totally valid. I'll check the standard tomorrow. The fact that clang doesn't complain indicates that this is fine. I'll still prefer to be sure before giving the ACK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/11124#discussion_r263549946
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190307/ba2bf520/attachment-0001.html>


More information about the notifications mailing list