[riot-notifications] [RIOT-OS/RIOT] ERROR: Timeout waiting for ACK/NACK after 'Synch (0x55 0x55)' (#11031)

Siddharth Gupta notifications at github.com
Sat Mar 9 06:49:08 CET 2019


@mohanmaniramesh @MrKevinWeiss 
I am using the openmote-B for a research project, and had borrowed a few devices from my university lab. When I first tried to flash the devices I was getting the same error:

`Timeout waiting for ACK/NACK after 'Synch (0x55 0x55)'`

Initially, I thought that it was not selecting the right port and started looking in my /dev folder to figure out the port and found 2 ports belonging to the mote `tty.usbserial-xxxx0` and `tty.usbserial-xxxx1`.

I then tried flashing the device with port `tty.usbserial-xxxx1` using the command:

`$ BOARD=openmote-b PORT=/dev/tty.usbserial-xxxx1 make flash`

This was the command that was being called for flashing though:
`{path_to_RIOT}/dist/tools/cc2538-bsl/cc2538-bsl.py -p "/dev/tty.usbserial-14200" --bootloader-invert-lines -e -w -v -b 460800 {path_to_RIOT}/examples/gnrc_networking/bin/openmote-b/gnrc_networking.bin`

This did not work as the script for some reason was still taking the old port (i.e. `tty.usbserial-xxxx0`). So I manually copied the command and modified the flashing command to use port `tty.usbserial-xxxx1`:

`{path_to_RIOT}/dist/tools/cc2538-bsl/cc2538-bsl.py -p "/dev/tty.usbserial-14201" --bootloader-invert-lines -e -w -v -b 460800 {path_to_RIOT}/examples/gnrc_networking/bin/openmote-b/gnrc_networking.bin`

 I was successfully able to flash the code and able to use `make term` on this port. Hopefully this helps someone who is stuck in a similar situation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/issues/11031#issuecomment-471148748
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190308/9fe1c3ed/attachment.html>


More information about the notifications mailing list