[riot-notifications] [RIOT-OS/RIOT] pkg/pkg.mk: make sure we are building the correct commit. (#11129)

Juan I Carrano notifications at github.com
Thu Mar 14 15:57:18 CET 2019


@dylad I think that we should see versions (at least now, with the current model) as a "hard" requirement. The reason is that it is impossible to know if the old version works fine, or has incompatibilities, or a security issue or a bug. If we were using a kind of "version number" scheme, we would be able to be a bit smarter on wether we can fulfill the requirements without upgrading, but as it is now, allowing that kind of behavior can possibly lead to errors.

Why not define an "update-tools" target instead? That way you can be sure that you have up-to date tools for whatever version of RIOT you may be using.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/11129#issuecomment-472902424
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190314/f718b19b/attachment.html>


More information about the notifications mailing list