[riot-notifications] [RIOT-OS/RIOT] pkg/lua: Make the module searchers conform to the API. (#9726)

Leandro Lanzieri notifications at github.com
Fri May 31 15:00:23 CEST 2019


leandrolanzieri commented on this pull request.



> +#!/usr/bin/env python3
+
+# Copyright (C) 2019 Freie Universit├Ąt Berlin
+#
+# This file is subject to the terms and conditions of the GNU Lesser
+# General Public License v2.1. See the file LICENSE in the top level
+# directory for more details.
+
+# Tell the lua interpreter running in riot to load some modules and print
+# the value of a variable inside that module.
+
+import os
+import sys
+
+MODULE_QUERIES = [
+    ("m1", "a", "1"),

I just realized, if the expected value matches the module name, then the `expect_exact` will pass no matter the returned value, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/9726#pullrequestreview-244293882
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190531/df7cf2a3/attachment.html>


More information about the notifications mailing list