[riot-notifications] [RIOT-OS/RIOT] pkg/oonf_api: deprecate package (#12190)

benpicco notifications at github.com
Tue Sep 10 15:59:06 CEST 2019


### Contribution description
`tests/pkg_oonf_api` is a no-op. oonf_api contains it's own suite of test that were also ported to RIOT.
When I cleaned those up and thought about how they could be integrated into CI, I was seriously wondering if the package is still used by anymore.

 - oonf_api has not been updated in 6 years, it's stil at 0.3.0 from 2013.
 - tests were never integrated into CI
 - With NHDP the only upstream user of the package is deprecated.
 - Downstream users would rather prefer a less vintage version of the library.

So unless someone actually still has a use for this vintage pkg, I think we should better do away with it entirely. To be useful it would need to be updated to a more recent version and the unit tests would need to be integrated into our CI.

### Testing procedure
Make sure you have no use for the package anymore.

### Issues/PRs references
obsoletes #12184
You can view, comment on, or merge this pull request online at:

  https://github.com/RIOT-OS/RIOT/pull/12190

-- Commit Summary --

  * pkg/oonf_api: deprecate package

-- File Changes --

    A pkg/oonf_api/doc.txt (11)

-- Patch Links --

https://github.com/RIOT-OS/RIOT/pull/12190.patch
https://github.com/RIOT-OS/RIOT/pull/12190.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/12190
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190910/f2224044/attachment-0001.htm>


More information about the notifications mailing list