[riot-notifications] [RIOT-OS/RIOT] gnrc_tcp: Always ensure that option->length doesn't exceed opt_left (#12253)

nmeum notifications at github.com
Mon Sep 16 17:54:00 CEST 2019


Noticed this while working on #12249 the MSS option length of a malicious packet might exceed `opt_left`.  
You can view, comment on, or merge this pull request online at:

  https://github.com/RIOT-OS/RIOT/pull/12253

-- Commit Summary --

  * gnrc_tcp: Always ensure that option->length doesn't exceed opt_left

-- File Changes --

    M sys/net/gnrc/transport_layer/tcp/gnrc_tcp_option.c (2)

-- Patch Links --

https://github.com/RIOT-OS/RIOT/pull/12253.patch
https://github.com/RIOT-OS/RIOT/pull/12253.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/12253
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190916/8f0abe42/attachment-0001.htm>


More information about the notifications mailing list