[riot-notifications] [RIOT-OS/RIOT] dhcpv6: Initial implementation of a client (with IA_PD support) (#8796)

benpicco notifications at github.com
Tue Sep 24 01:59:40 CEST 2019


I'm not sure how to use this.

I have an `esp8266-esp-12x` that connects to my WiFi which has a native IPv6 Uplink and a Fritz!Box acting as DHCPv6 server.

I tried adding `USEMODULE += dhcpv6_client auto_init_dhcpv6_client esp_wifi` to the Makefile in `examples/gnrc_networking`, but I would not get an IP address or prefix.

```
2019-09-24 01:52:53,225 - INFO # Iface  7  HWaddr: 80:7D:3A:7F:E0:1D  Link: up 
2019-09-24 01:52:53,230 - INFO #           L2-PDU:1500 MTU:1500  HL:64  RTR  
2019-09-24 01:52:53,230 - INFO #           RTR_ADV  
2019-09-24 01:52:53,234 - INFO #           Source address length: 6
2019-09-24 01:52:53,237 - INFO #           Link type: wireless
2019-09-24 01:52:53,242 - INFO #           inet6 addr: fe80::827d:3aff:fe7f:e01d  scope: local  VAL
2019-09-24 01:52:53,245 - INFO #           inet6 group: ff02::2
2019-09-24 01:52:53,248 - INFO #           inet6 group: ff02::1
2019-09-24 01:52:53,253 - INFO #           inet6 group: ff02::1:ff7f:e01d
2019-09-24 01:52:53,256 - INFO #           inet6 group: ff02::1a
2019-09-24 01:52:53,256 - INFO #           
2019-09-24 01:52:53,259 - INFO #           Statistics for Layer 2
2019-09-24 01:52:53,262 - INFO #             RX packets 200  bytes 18679
2019-09-24 01:52:53,267 - INFO #             TX packets 18 (Multicast: 16)  bytes 1258
2019-09-24 01:52:53,270 - INFO #             TX succeeded 14 errors 0
2019-09-24 01:52:53,273 - INFO #           Statistics for IPv6
2019-09-24 01:52:53,275 - INFO #             RX packets 41  bytes 4086
2019-09-24 01:52:53,281 - INFO #             TX packets 18 (Multicast: 16)  bytes 1360
2019-09-24 01:52:53,285 - INFO #             TX succeeded 18 errors 0
```
(I can ping the link-local address just fine from my computer).

I then tried adding the `_dhcpv6_client_thread` from `tests/gnrc_dhcpv6_client/main.c`, also started the thread with a 10s delay to give the WiFi time to connect - but still no global prefix.

My Router configuration looks like this:

![ipv6](https://user-images.githubusercontent.com/1301112/65470796-fcc34280-de6c-11e9-96cf-4353fdaddbd1.png)

I also tried IA_PD only but nothing changes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/8796#issuecomment-534330346
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190923/20fd0ee3/attachment.htm>


More information about the notifications mailing list