[riot-notifications] [RIOT-OS/RIOT] gnrc_tcp: test improvement (#11930)

Martine Lenders notifications at github.com
Mon Sep 30 15:05:48 CEST 2019


- `native` still works
- `samr21-xpro` still doesn't run reliably with test 4 :-/. However, I think it is just because of a too tight timeout for the expect. I ran it a couple of times (>10) with
  ```diff
  diff --git a/tests/gnrc_tcp/tests/04-receive_data.py b/tests/gnrc_tcp/tests/04-receive_data.py
  index 23d246d83f..f43634f035 100755
  --- a/tests/gnrc_tcp/tests/04-receive_data.py
  +++ b/tests/gnrc_tcp/tests/04-receive_data.py
  @@ -43,7 +43,7 @@ def testfunc(child):
   
       # Accept Data sent by the host system
       child.sendline('gnrc_tcp_recv 1000000 ' + str(data_len))
  -    child.expect_exact('gnrc_tcp_recv: received ' + str(data_len))
  +    child.expect_exact('gnrc_tcp_recv: received ' + str(data_len), timeout=20)
   
       # Close connection and verify that pktbuf is cleared
       child.sendline('gnrc_tcp_close')
  
  ```
  and didn't run into any errors yet.

Please add a note that due to `sudo ./start_network.sh ...` the test requires `sudo` (I always get an error without any indication what's happening). See e.g. https://github.com/RIOT-OS/RIOT/blob/fe6d892969a96dc86b961ee906cce96c0fa51ff1/tests/gnrc_ipv6_ext/tests/01-run.py#L641-L645

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/11930#issuecomment-536551735
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190930/99cc8cc6/attachment.htm>


More information about the notifications mailing list