[riot-notifications] [RIOT-OS/RIOT] drivers/at86rf215: Add driver for the AT86RF215 dual-band IEEE 802.15.4-2015 radio (#12128)

benpicco notifications at github.com
Mon Sep 30 18:13:37 CEST 2019


Interesting!

Can you try `udp server start 1234` on one node and `udp send <ip> 1234 Hello` on the other?

I just tried it and got the packet twice which indicates the ack timeout might not be correct yet.
You can also observe this effect when doing a broadcast ping

```
2019-09-30 18:13:09,323 - INFO # ping6 ff02::1%7
2019-09-30 18:13:09,339 - INFO # 12 bytes from fe80::f873:8230:d3e:1b8f: icmp_seq=0 ttl=64 rssi=-45 dBm time=9.064 ms
2019-09-30 18:13:09,348 - INFO # 12 bytes from fe80::f873:8230:d3e:1b8f: icmp_seq=0 ttl=64 rssi=-45 dBm time=17.388 ms (DUP!)
2019-09-30 18:13:10,339 - INFO # 12 bytes from fe80::f873:8230:d3e:1b8f: icmp_seq=1 ttl=64 rssi=-50 dBm time=9.064 ms
2019-09-30 18:13:10,348 - INFO # 12 bytes from fe80::f873:8230:d3e:1b8f: icmp_seq=1 ttl=64 rssi=-50 dBm time=17.387 ms (DUP!)
2019-09-30 18:13:11,340 - INFO # 12 bytes from fe80::f873:8230:d3e:1b8f: icmp_seq=2 ttl=64 rssi=-50 dBm time=9.066 ms
2019-09-30 18:13:11,341 - INFO # 
2019-09-30 18:13:11,342 - INFO # --- ff02::1 PING statistics ---
2019-09-30 18:13:11,349 - INFO # 3 packets transmitted, 3 packets received, 2 duplicates, 0% packet loss
2019-09-30 18:13:11,353 - INFO # round-trip min/avg/max = 9.064/12.393/17.388 ms
```

Now why this leads to you not getting any replies I don't know.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/12128#issuecomment-536635495
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20190930/1c1024f0/attachment.htm>


More information about the notifications mailing list