[riot-notifications] [RIOT-OS/RIOT] esptool.py: use python3 (#14033)

benpicco notifications at github.com
Wed May 6 16:41:02 CEST 2020


### Contribution description

Be explicit about which python is used, as otherwise some distributions (e.g. Ubuntu) will default to Python 2.


### Testing procedure

<!--
Details steps to test your contribution:
- which test/example to compile for which board and is there a 'test' command
- how to know that it was not working/available in master
- the expected success test output
-->


### Issues/PRs references

I would suddenly get this error https://github.com/espressif/esptool/issues/350 after upgrading to Ubuntu 20.04
Using Python3 fixed it.

You can view, comment on, or merge this pull request online at:

  https://github.com/RIOT-OS/RIOT/pull/14033

-- Commit Summary --

  * esptool.py: use python3

-- File Changes --

    M dist/tools/esptool/esptool.py (2)

-- Patch Links --

https://github.com/RIOT-OS/RIOT/pull/14033.patch
https://github.com/RIOT-OS/RIOT/pull/14033.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/14033
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20200506/4afac1d4/attachment.htm>


More information about the notifications mailing list