[riot-notifications] [RIOT-OS/RIOT] esptool.py: use upstream version, switch to python3 (#14033)

Gunar Schorcht notifications at github.com
Thu May 7 08:02:34 CEST 2020


> (Also includes support for ESP32-S2 now)

I don't think that we will be able to support ESP32-S because it requires a much newer ESP-IDF version, I guess 4.1. We still use version 3.1 and it would not be easy to port the current RIOT implementation for ESP32 to this new ESP-IDF version. The reason is, that the RIOT port for ESP32 can't use the FreeRTOS based ESP-IDF. Rather it is uses a mixture of vendor code extracted from the ESP-IDF and changed vendor code to make it working with RIOT. I guess that a change from 3.1 to 4.1 would require to reimplement large parts of the RIOT port for ESP32 :worried:

I have tried such a version upgrade for the ESP8266. I have been working on it for 4 months and it is still not finished. So for now I would prefer to leave the ESP32 port as it is and continue using ESP-IDF version 3.1. In this respect, support for the ESP32-S is not a problem.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/14033#issuecomment-625046916
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20200506/9d1123ff/attachment.htm>


More information about the notifications mailing list