[riot-notifications] [RIOT-OS/RIOT] esptool.py: use upstream version, switch to python3 (#14033)

benpicco notifications at github.com
Thu May 7 10:32:25 CEST 2020


> I don't think that we will be able to support ESP32-S because it requires a much newer ESP-IDF version

No pressure :wink: 
I just thought that would be a nice bonus.

In the first version of this PR I just replaced `#!/usr/bin/env python` with `#!/usr/bin/env python3` because of the error I got (missing Python 2 libraries) and all the other tools in RIOT use Python 3.

I then stared to wonder why we keep a copy of `esptool.py` in the RIOT repo, as this encourages modifying it, which makes upgrades harder.

So I replaced it with a pkg like it's done with other tools that have an upstream.
Upstream still didn't switch to Python3, so I added the patch, but now to the pkg.



-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/14033#issuecomment-625111552
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20200507/12e3bb7b/attachment.htm>


More information about the notifications mailing list